Openads 2.3 Hell

Openads 2.3 is a hell to use .. it’s new, it’s fresh, it’s a  huge update compared to 2.0 and after installing and using it: it’s a hell on cache level.

I have a lot of ‘single’ banners with single zone and when I try to embed it I see all kinds of other banners displayed .. After searching for ours it seems that when deleting the cache folder the ads / images are displayed correctly. This is really a mess and terrible and absolutely not seen in a previous version of Openads ..

:: Update ::

message to self: when removing the cache files: hell becomes heaven.  Issues seems to be solved that way. Thanks for the update Oliver.

3 thoughts on “Openads 2.3 Hell

  1. Hello Dennis

    Upgrading from 2.0 to 2.3 should be smooth.

    I didn’t quite understand your description of the problem but I’d like to try to understand what went wrong for you. Can you tell me a little more about what happened.

    A couple of points to start…

    Q1. If you were you upgrading from 2.0 to 2.3 then I would expect the existing tags to continue working. Why did you need to embed new tags afterwards?

    Q2. You mention seeing other banners being displayed. Were they other banners which you knew: ones which you had loaded yourself but which you didn’t expect to see in a particular zone?

    cheers,
    Oliver George
    Openads Ltd

  2. >
    >
    > Upgrading from 2.0 to 2.3 should be smooth.
    >
    Upgrading from 2.0 to 2.3 is smooth, but has some things you do not expect as 2.0 user ;-)
    Ie. the change in config file behaviour.
    the 2.0 has a config php file where the 2.3 has a file which is controlled by ‘apache’, but when users have only FTP access and no access to any ‘chown’ feature
    than it will be a hassle to fix that without the help of any administrator

    Than about my issue

    First of all my system is: Apache 2.0.52, PHP 4.3.9 and MySQL 4.1.20-.
    A CentOS 4 installation with BlueQuartz
    so yes the 4.3.9 is not the advised 4.3.11 ..

    >
    > Q1. If you were you upgrading from 2.0 to 2.3 then I would expect the existing tags to continue working. Why did you need to embed new tags afterwards?
    >
    Oh .. no this is something completely else and has nothing to do with the openads part ..

    > Q2. You mention seeing other banners being displayed. Were they other banners which you knew: ones which you had loaded yourself but which you didn’t expect to see in a particular zone?
    >
    The main issue is that I changed my banners from included in the mysql database to images on the webserver itself, so my images had to be updated and I wanted to have better php code / javascript
    than I noticed that nothing changed no matter what option I made or changed.

    Finally after 2 or 3 installations (different virtual sites on my box) I discovered that I had to manually remove the contents of my cache folder to see the changes in affect.
    So I have 5 campaigns, with different banners and 5 zones when I add a banner from a campaign to a zone the new banner will only be shown when I remove the content of the cache (var/cache)
    and refresh the pages ..

    So to find this out it was a hell cause it took me my weekend ;-) but now happy with the new version ;-)

    Dennis

Leave a Reply

Your email address will not be published. Required fields are marked *