14 thoughts on “CH3HNAS: Beta firmware 2.3.44

  1. Rene says:

    je beta firmware ben ik aan het proberen omdat de originele fw extreem langzaam is (800kb/s) terwijl je beta gewoon 14Mb/s geeft.
    Helaas krijg ik met het uploaden van bestanden na ongeveer 13Gb een error en is de disk niet meer te benaderen (hij unmount hem), met 2 verschillende schijven geprobeerd, beide met diskcheck extern gecontrolleerd maar fout blijft.
    Enig idee hoe dit komt (nog niet met originele fw getest omdat dan tot 13Gb kopieren ongeveer 6 uur duurt).

    Het gaat in beide gevallen om een samsung 500Gb HD (HD501LJ).
    Het log geeft dit aan:

    May 15 14:03:33 NAS kernel: sd 0:0:0:0: [sda] Result: hostbyte=0x04 driverbyte=0x00
    May 15 14:03:33 NAS kernel: end_request: I/O error, dev sda, sector 62273615
    May 15 14:03:33 NAS kernel: sd 0:0:0:0: [sda] Result: hostbyte=0x04 driverbyte=0x00
    May 15 14:03:33 NAS kernel: end_request: I/O error, dev sda, sector 62274639
    May 15 14:03:33 NAS kernel: sd 0:0:0:0: [sda] Result: hostbyte=0x04 driverbyte=0x00
    May 15 14:03:33 NAS kernel: end_request: I/O error, dev sda, sector 62212647
    May 15 14:03:33 NAS kernel: sd 0:0:0:0: [sda] Result: hostbyte=0x04 driverbyte=0x00
    May 15 14:03:33 NAS kernel: end_request: I/O error, dev sda, sector 62213671
    May 15 14:03:33 NAS kernel: sd 0:0:0:0: [sda] Result: hostbyte=0x04 driverbyte=0x00
    May 15 14:03:33 NAS kernel: end_request: I/O error, dev sda, sector 62214695
    May 15 14:03:33 NAS kernel: sd 0:0:0:0: [sda] Result: hostbyte=0x04 driverbyte=0x00
    May 15 14:03:33 NAS kernel: end_request: I/O error, dev sda, sector 62275663
    May 15 14:03:33 NAS kernel: sd 0:0:0:0: [sda] Result: hostbyte=0x04 driverbyte=0x00
    May 15 14:03:33 NAS kernel: end_request: I/O error, dev sda, sector 62276687
    May 15 14:03:33 NAS kernel: sd 0:0:0:0: [sda] Result: hostbyte=0x04 driverbyte=0x00
    May 15 14:03:33 NAS kernel: end_request: I/O error, dev sda, sector 62277671
    May 15 14:03:33 NAS kernel: sd 0:0:0:0: [sda] Result: hostbyte=0x04 driverbyte=0x00
    May 15 14:03:33 NAS kernel: end_request: I/O error, dev sda, sector 62278695
    May 15 14:03:33 NAS kernel: sd 0:0:0:0: [sda] Result: hostbyte=0x04 driverbyte=0x00
    May 15 14:03:33 NAS kernel: end_request: I/O error, dev sda, sector 62279719
    May 15 14:03:33 NAS kernel: Buffer I/O error on device sda1, logical block 7776573
    May 15 14:03:33 NAS kernel: sd 0:0:0:0: [sda] Result: hostbyte=0x04 driverbyte=0x00
    May 15 14:03:33 NAS kernel: end_request: I/O error, dev sda, sector 62280743
    May 15 14:03:33 NAS kernel: sd 0:0:0:0: [sda] Result: hostbyte=0x04 driverbyte=0x00
    May 15 14:03:33 NAS kernel: end_request: I/O error, dev sda, sector 62281735
    May 15 14:03:33 NAS kernel: sd 0:0:0:0: [sda] Result: hostbyte=0x04 driverbyte=0x00
    May 15 14:03:33 NAS kernel: end_request: I/O error, dev sda, sector 488387289
    May 15 14:03:33 NAS kernel: lost page write due to I/O error on sda1
    May 15 14:03:33 NAS kernel: Buffer I/O error on device sda1, logical block 7776574
    May 15 14:03:33 NAS kernel: lost page write due to I/O error on sda1
    May 15 14:03:33 NAS kernel: Buffer I/O error on device sda1, logical block 7776575
    May 15 14:03:33 NAS kernel: lost page write due to I/O error on sda1
    May 15 14:03:33 NAS kernel: Buffer I/O error on device sda1, logical block 7776576
    May 15 14:03:33 NAS kernel: lost page write due to I/O error on sda1
    May 15 14:03:33 NAS kernel: Buffer I/O error on device sda1, logical block 7776577
    May 15 14:03:33 NAS kernel: lost page write due to I/O error on sda1
    May 15 14:03:33 NAS kernel: Buffer I/O error on device sda1, logical block 7776578
    May 15 14:03:33 NAS kernel: lost page write due to I/O error on sda1
    May 15 14:03:33 NAS kernel: Buffer I/O error on device sda1, logical block 7776579
    May 15 14:03:33 NAS kernel: lost page write due to I/O error on sda1
    May 15 14:03:33 NAS kernel: Buffer I/O error on device sda1, logical block 7776580
    May 15 14:03:33 NAS kernel: lost page write due to I/O error on sda1
    May 15 14:03:33 NAS kernel: Buffer I/O error on device sda1, logical block 7776581
    May 15 14:03:33 NAS kernel: lost page write due to I/O error on sda1
    May 15 14:03:33 NAS kernel: Buffer I/O error on device sda1, logical block 7776582
    May 15 14:03:33 NAS kernel: lost page write due to I/O error on sda1
    May 15 14:03:33 NAS kernel: I/O error in filesystem (“sda1”) meta-data dev sda1 block 0x1d1c329a (“xlog_iodone”) error 5 buf count 7680
    May 15 14:03:33 NAS kernel: xfs_force_shutdown(sda1,0x2) called from line 996 of file fs/xfs/xfs_log.c. Return address = 0xc0195008
    May 15 14:03:33 NAS kernel: Filesystem “sda1”: Log I/O Error Detected. Shutting down filesystem: sda1
    May 15 14:03:33 NAS kernel: Please umount the filesystem, and rectify the problem(s)

  2. lijkt er wel op of er iets mis is met je HDD
    Ik zal van de week eens wat grote M2TS bestanden naar toe pompen.

    Wat doen je? Samba of FTP ?

    Zie je hierin ook verschil?

  3. Rene says:

    Ik gebruik gewoon samba, heb nu al 2 HDDs geprobeerd en beide geven dezelfde problemen.
    (ook beide helemaal geverifieerd en werken 100% goed)

    Ik heb hem echt alleen gekocht om een simpele NAS te hebben dus als ik dit samba gedeelte gewoon niet goed krijg dan heb ik er echt niks aan, jammer dat ze hier niet wat tijd en moeite in hebben gestopt om goed door te testen.

  4. Rene says:

    bedenk me net dat evt de aansluiting niet goed kan zijn, als ik met de originele fw ook weer de problemen krijg zal ik de HDD eens op de 2e aansluiting zetten (heb er maar 1 inzitten nu) kijken of het niet gewoon een fabrieksfout is.

  5. Rene: wellicht dat er iets mis gaat met de caching and de wijze waarop betere performance is gekregen.
    er is uitgebreid getest, echter in verschillende firmwares kunnen allerlei dingen de kop op steken. En reken maar dat er aan gewerkt wordt.

  6. @luco: dat was ook de bedoeling ;-)
    probleem van Rene nog niet kunnen reproduceren, al vele gigabytes gepompt maar noppes .. dus incidenteel probleem zo lijkt het

  7. Rene says:

    Dennis,

    ik heb er maar 1 HDD ingestopt om te testen.
    Dus gewoon 1 HDD op de 1e aansluiting zonder enige vorm van RAID.

  8. Jorge says:

    Hi,
    I wonder if you could help me solve a problem with my CH3HNAS.

    Using windows vista backup to a password protected samba share always fails exactly as described here:

    http://lists.samba.org/archive/samba-technical/2007-January/051318.html

    Apparently, a newer (since 2007) samba version solves this specific incompatibility, but I couldn’t find the which version I’m running.

    My firmware is CH3HNAS_v2.3.44 (final version from the support website).

    Another thing: works fine with win7..

    Thanks

  9. Herman says:

    Oke, zelfde probleem hier: na ongeveer 10 giga upload crashed de nas. Disks niet meer benaderbaar. Data verloren.
    Gen vermeldingen in de logs! Kwalijke zaak, mag ik wel zeggen. Ben al 20 jaar AIX/UNIX beheerder maar begrijp hier niks van. Slecht product? Ik gebruik 2 identieke harddisks van 500 giga. Kleine bestanden gaat prima, grotere dus niet. En daar heb ik het ding nou precies voor.
    Als ik een eerdere firmware moet laden hoor ik het graag. Zo heb ik er bijzonder weinig aan.
    Bij voorbaat dank

Leave a Reply

Your email address will not be published. Required fields are marked *